re = /(\.[a-z]*)\/administrator/
str = 'http://m1.aa.example.com/administrator
http://m2.aa.example.com/administrator
http://m5.aa.example.com/administrator
http://m1.bb.example.com/administrator
http://m2.bb.example.com/administrator'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result