re = /`[^`]*`\.`[^`]*`/
str = 'SELECT `asd`.`ssss` as `column1`, `ss`.`wwwwwww` from `table`'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end