package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([+]{0,1}[\d]{1,5}[\s]{0,1}[\/]{0,1}[(]{0,1}[\d]{0,3}[)]{0,1}\s{0,1}\d{2,4}[-]{0,1}[\s]{0,1}[\d]{2,4}[-]{0,1}[\s]{0,1}[\d]{1,4})`)
var str = `061 833 315
+387 61 853 512
moj broj telefona je +385 (99) 223-45-67
drugi broj 061/865-326 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}