const regex = /([+]{0,1}[\d]{1,5}[\s]{0,1}[\/]{0,1}[(]{0,1}[\d]{0,3}[)]{0,1}\s{0,1}\d{2,4}[-]{0,1}[\s]{0,1}[\d]{2,4}[-]{0,1}[\s]{0,1}[\d]{1,4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([+]{0,1}[\\d]{1,5}[\\s]{0,1}[\\\/]{0,1}[(]{0,1}[\\d]{0,3}[)]{0,1}\\s{0,1}\\d{2,4}[-]{0,1}[\\s]{0,1}[\\d]{2,4}[-]{0,1}[\\s]{0,1}[\\d]{1,4})', 'gm')
const str = `061 833 315
+387 61 853 512
moj broj telefona je +385 (99) 223-45-67
drugi broj 061/865-326 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}