using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"src=""([^:""]+)""";
string input = @"<a href=#><img src=""images/smile.jpg"" id=""smile""></a>
<img src=""http://full.url.is.not.processed/smile.jpg"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}