$re = '/src="([^:"]+)"/';
$str = '<a href=#><img src="images/smile.jpg" id="smile"></a>
<img src="http://full.url.is.not.processed/smile.jpg">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);