#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ism)<body>(.*?)<\/body>"
Local $sString = "" & @CRLF & _
"<!doctype html>" & @CRLF & _
"<head>" & @CRLF & _
" <meta charset="utf-8">" & @CRLF & _
" <meta name="viewport" content="width=device-width, initial-scale=1.0">" & @CRLF & _
" <meta name="description" content="">" & @CRLF & _
" <meta name="author" content="">" & @CRLF & _
"" & @CRLF & _
" <link href="http://localhost//themes/default/../dashboard/css/bootstrap.min.css" rel="stylesheet" type="text/css" />" & @CRLF & _
"" & @CRLF & _
" <link rel="stylesheet" type="text/css" href="http://localhost//assets/cache/default_product_groups_product_groups_mod.css" media="screen" />" & @CRLF & _
" <link rel="shortcut icon" href="http://localhost//favicon.ico">" & @CRLF & _
"</head>" & @CRLF & _
"" & @CRLF & _
"<body>" & @CRLF & _
" <p dir='rtl'>" & @CRLF & _
" <a target='_blank' href='https://zuz.mx/2e5y'>לרכישה מכאן במחיר 37.01$</a>" & @CRLF & _
" </p>" & @CRLF & _
"" & @CRLF & _
" <input id="base_url_special" type="hidden" name="base_url_special" value="http://localhost//"/>" & @CRLF & _
"" & @CRLF & _
"</body>" & @CRLF & _
"<script src="http://localhost//themes/default/js/jquery.min.js" type="text/javascript"></script>" & @CRLF & _
"" & @CRLF & _
"<script src="http://localhost//assets/cache/default_fetchPG_product_groups_mod.js?_dt=1492617362" type="text/javascript"></script>" & @CRLF & _
"<script src="http://localhost//themes/default/../dashboard/js/bootstrap.min.js" type="text/javascript"></script>" & @CRLF & _
"" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")