# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<body>(.*?)<\/body>"
test_str = ("\n"
"<!doctype html>\n"
"<head>\n"
" <meta charset=\"utf-8\">\n"
" <meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0\">\n"
" <meta name=\"description\" content=\"\">\n"
" <meta name=\"author\" content=\"\">\n\n"
" <link href=\"http://localhost//themes/default/../dashboard/css/bootstrap.min.css\" rel=\"stylesheet\" type=\"text/css\" />\n\n"
" <link rel=\"stylesheet\" type=\"text/css\" href=\"http://localhost//assets/cache/default_product_groups_product_groups_mod.css\" media=\"screen\" />\n"
" <link rel=\"shortcut icon\" href=\"http://localhost//favicon.ico\">\n"
"</head>\n\n"
"<body>\n"
" <p dir='rtl'>\n"
" <a target='_blank' href='https://zuz.mx/2e5y'>לרכישה מכאן במחיר 37.01$</a>\n"
" </p>\n\n"
" <input id=\"base_url_special\" type=\"hidden\" name=\"base_url_special\" value=\"http://localhost//\"/>\n\n"
"</body>\n"
"<script src=\"http://localhost//themes/default/js/jquery.min.js\" type=\"text/javascript\"></script>\n\n"
"<script src=\"http://localhost//assets/cache/default_fetchPG_product_groups_mod.js?_dt=1492617362\" type=\"text/javascript\"></script>\n"
"<script src=\"http://localhost//themes/default/../dashboard/js/bootstrap.min.js\" type=\"text/javascript\"></script>\n\n"
"</body>\n"
"</html>")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.DOTALL | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.