const regex = /(?<=NASDAQ:).*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=NASDAQ:).*', 'gi')
const str = `
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:INM
Go to Screener
Thanks for reading,
Team TradingView
470 Olde Worthing Rd., Suite 200
Westerville OH 43082
Download on the App Store Get it on Google Play
TradingView on Youtube
This email was sent @gmail.com
because you asked to be alerted on TradingView.com
TradingView <noreply@tradingview.com>
17 Nov 2021, 14:32 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:GSMG, NASDAQ:VRAR
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 14:34 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:BLZE, NASDAQ:GOEV, NASDAQ:VIR, NYSE:ZIM
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 14:35 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NYSE:TJX
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 14:36 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:BBBY, NASDAQ:NEGG
Go to Screener
TradingView
17 Nov 2021, 14:38 (1 day ago)
Your alert was triggered New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+ Check out the following new tickers: NASDAQ:NEGG, NASDAQ:EYPT Go to Screen
TradingView <noreply@tradingview.com>
17 Nov 2021, 14:39 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:INSG, NASDAQ:XERS
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 14:40 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:NEGG
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 14:41 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:INSG
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 14:42 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:BBBY, NASDAQ:PPSI, NASDAQ:SPI, NASDAQ:APWC
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 14:43 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:BRPM
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 14:44 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:GSM, NASDAQ:NEGG, NASDAQ:PCT
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 14:56 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:BLZE
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 14:58 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:OEG
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 15:14 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:INM
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 15:26 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:EYPT
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 15:34 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:SEV
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 15:40 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:FNHC
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 15:44 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NYSE:ZME
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 16:07 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: AMEX:SBEV
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 16:13 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NYSE:ZME
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 16:37 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:IMV
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 16:39 (1 day ago)
TradingView <noreply@tradingview.com>
17 Nov 2021, 16:43 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:AGTC
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 17:34 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:AESE
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 17:49 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NYSE:ZME
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 17:55 (1 day ago)
TradingView <noreply@tradingview.com>
17 Nov 2021, 17:56 (1 day ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:WORX
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 17:59 (1 day ago)
TradingView <noreply@tradingview.com>
17 Nov 2021, 18:38 (23 hours ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:ENSC
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 19:29 (22 hours ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:SABS
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 19:52 (22 hours ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:HMTV
Go to Screener
TradingView <noreply@tradingview.com>
17 Nov 2021, 20:41 (21 hours ago)
TradingView
Your alert was triggered
New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+
Check out the following new tickers: NASDAQ:BLBX`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}