import re
regex = re.compile(r"(?<=NASDAQ:).*", flags=re.IGNORECASE)
test_str = ("\n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:INM\n\n"
" \n"
"Go to Screener\n"
" \n"
" \n"
"Thanks for reading,\n"
"Team TradingView\n\n"
"470 Olde Worthing Rd., Suite 200\n"
"Westerville OH 43082\n\n"
"Download on the App Store Get it on Google Play\n\n"
" TradingView on Youtube \n\n"
" \n"
" \n"
"This email was sent @gmail.com\n"
"because you asked to be alerted on TradingView.com\n\n"
" \n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 14:32 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:GSMG, NASDAQ:VRAR\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 14:34 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:BLZE, NASDAQ:GOEV, NASDAQ:VIR, NYSE:ZIM\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 14:35 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NYSE:TJX\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 14:36 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:BBBY, NASDAQ:NEGG\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView\n"
"17 Nov 2021, 14:38 (1 day ago)\n"
"Your alert was triggered New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+ Check out the following new tickers: NASDAQ:NEGG, NASDAQ:EYPT Go to Screen\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 14:39 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:INSG, NASDAQ:XERS\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 14:40 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:NEGG\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 14:41 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:INSG\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 14:42 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:BBBY, NASDAQ:PPSI, NASDAQ:SPI, NASDAQ:APWC\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 14:43 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:BRPM\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 14:44 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:GSM, NASDAQ:NEGG, NASDAQ:PCT\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 14:56 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:BLZE\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 14:58 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:OEG\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 15:14 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:INM\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 15:26 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:EYPT\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 15:34 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:SEV\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 15:40 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:FNHC\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 15:44 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NYSE:ZME\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 16:07 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: AMEX:SBEV\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 16:13 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NYSE:ZME\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 16:37 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:IMV\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 16:39 (1 day ago)\n\n\n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 16:43 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:AGTC\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 17:34 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:AESE\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 17:49 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NYSE:ZME\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 17:55 (1 day ago)\n\n\n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 17:56 (1 day ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:WORX\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 17:59 (1 day ago)\n\n\n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 18:38 (23 hours ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:ENSC\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 19:29 (22 hours ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:SABS\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 19:52 (22 hours ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:HMTV\n\n"
" \n"
"Go to Screener\n"
" \n\n\n"
"TradingView <noreply@tradingview.com>\n"
"17 Nov 2021, 20:41 (21 hours ago)\n\n\n"
" \n"
"TradingView \n"
" \n\n"
" \n\n"
" \n"
"Your alert was triggered\n"
" \n"
"New Volatility - B/out +7.5% (15 minutes) - Vol-100k+, RV-5+\n\n"
" \n"
"Check out the following new tickers: NASDAQ:BLBX")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")