#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]:\\windows\\temp\\(.*?){7,10}\.exe"
Local $sString = "c:\windows\temp\bob-1234.exe" & @CRLF & _
"c:\windows\temp\_yellow_po.exe """ & @CRLF & _
"c:\windows\temp\pTUNE-UP8.exe """
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")