$re = '/^[a-zA-Z]:\\\\windows\\\\temp\\\\(.*?){7,10}\.exe/m';
$str = 'c:\\windows\\temp\\bob-1234.exe
c:\\windows\\temp\\_yellow_po.exe ""
c:\\windows\\temp\\pTUNE-UP8.exe ""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);