re = /(?<=;Password=)(?:(?!;[\w ]+=).)*/i
str = 'add key="myKey" value="Data Source=MyDataSource;Initial Catalog=MyDB;User ID=test-user;Password=pA&-pass; unicode=True"
add key="myKey" value="Data Source=MyDataSource;Initial Catalog=MyDB;User ID=test-user;Password=pass>; unicode=True"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end