import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div>((?:[^<]|<[^d]|<d[^i]|<di[^v]|<div[^>])*?)</div>";
final String string = "<div> foo <div> bar </div>\n\n"
+ " <div> bar </div> baz </div>\n\n"
+ "<div> foo <div> bar </div> baz </div>\n\n"
+ "<div>< <span>Foo</span> ></div>\n"
+ "<div>< <span>Foo</span> v></div>\n"
+ "<div>< <span>Foo</span> iv></div>\n"
+ "<div>< <span>Foo</span> div></div>\n"
+ "<div>< <span>Foo</span> /div></div>\n"
+ "<div>< <span>Foo</span> </div></div>\n"
+ "<div><d <span>Foo</span> ></div>\n"
+ "<div><d <span>Foo</span> v></div>\n"
+ "<div><d <span>Foo</span> iv></div>\n"
+ "<div><d <span>Foo</span> div></div>\n"
+ "<div><d <span>Foo</span> /div></div>\n"
+ "<div><d <span>Foo</span> </div></div>\n"
+ "<div><di <span>Foo</span> ></div>\n"
+ "<div><di <span>Foo</span> v></div>\n"
+ "<div><di <span>Foo</span> iv></div>\n"
+ "<div><di <span>Foo</span> div></div>\n"
+ "<div><di <span>Foo</span> /div></div>\n"
+ "<div><di <span>Foo</span> </div></div>\n"
+ "<div><div <span>Foo</span> ></div>\n"
+ "<div><div <span>Foo</span> v></div>\n"
+ "<div><div <span>Foo</span> iv></div>\n"
+ "<div><div <span>Foo</span> div></div>\n"
+ "<div><div <span>Foo</span> /div></div>\n"
+ "<div><div <span>Foo</span> </div></div>\n"
+ "<div><div> <span>Foo</span> ></div>\n"
+ "<div><div> <span>Foo</span> v></div>\n"
+ "<div><div> <span>Foo</span> iv></div>\n"
+ "<div><div> <span>Foo</span> div></div>\n"
+ "<div><div> <span>Foo</span> /div></div>\n"
+ "<div><div> <span>Foo</span> </div></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}