$re = '`<div>((?:[^<]|<[^d]|<d[^i]|<di[^v]|<div[^>])*?)</div>`m';
$str = '<div> foo <div> bar </div>
<div> bar </div> baz </div>
<div> foo <div> bar </div> baz </div>
<div>< <span>Foo</span> ></div>
<div>< <span>Foo</span> v></div>
<div>< <span>Foo</span> iv></div>
<div>< <span>Foo</span> div></div>
<div>< <span>Foo</span> /div></div>
<div>< <span>Foo</span> </div></div>
<div><d <span>Foo</span> ></div>
<div><d <span>Foo</span> v></div>
<div><d <span>Foo</span> iv></div>
<div><d <span>Foo</span> div></div>
<div><d <span>Foo</span> /div></div>
<div><d <span>Foo</span> </div></div>
<div><di <span>Foo</span> ></div>
<div><di <span>Foo</span> v></div>
<div><di <span>Foo</span> iv></div>
<div><di <span>Foo</span> div></div>
<div><di <span>Foo</span> /div></div>
<div><di <span>Foo</span> </div></div>
<div><div <span>Foo</span> ></div>
<div><div <span>Foo</span> v></div>
<div><div <span>Foo</span> iv></div>
<div><div <span>Foo</span> div></div>
<div><div <span>Foo</span> /div></div>
<div><div <span>Foo</span> </div></div>
<div><div> <span>Foo</span> ></div>
<div><div> <span>Foo</span> v></div>
<div><div> <span>Foo</span> iv></div>
<div><div> <span>Foo</span> div></div>
<div><div> <span>Foo</span> /div></div>
<div><div> <span>Foo</span> </div></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);