package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([.:]\d+|\d+([.:]\d+)?)$`)
var str = `87887
8787.878
8878:98
abc
989ab
8987.89:87
3
.33`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}