$re = '/^([.:]\d+|\d+([.:]\d+)?)$/m';
$str = '87887
8787.878
8878:98
abc
989ab
8987.89:87
3
.33';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);