package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-a-zA-Z.0-9]*@[-a-zA-Z0-9]*\.[a-z]{3}`)
var str = `CoreyMSchafer@gmail.com
corey.schafer@university.edu
corey-321-schafer@my-work.net`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}