$re = '/-d (([\'"]).+?(?<!\\\\)\2)(?=(?:[^\'"]*([\'"])[^\'"]*?\3)*[^\'"]*$)/m';
$str = '-d "abc"
-d \'abc\' "other arg"
"-d \'It\\\'s here\'"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);