re = /-d ((['"]).+?(?<!\\)\2)(?=(?:[^'"]*(['"])[^'"]*?\3)*[^'"]*$)/m
str = '-d "abc"
-d \'abc\' "other arg"
"-d \'It\\\'s here\'"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end