$re = '/([0-9\.]+)([A-Za-z]+)/m';
$str = '1.785K
10MEG
999.1V';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);