#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^(?:" & @CRLF & _
" (?P<entity>[^:]+)" & @CRLF & _
" (?::(?P<mode>[^:]+))?" & @CRLF & _
" (?P<paths>" & @CRLF & _
" (:(?P<path>[^:]+))+" & @CRLF & _
" )?" & @CRLF & _
")" & @CRLF & _
"$"
Local $sString = "teams" & @CRLF & _
"teams:read" & @CRLF & _
"teams:read:abc123" & @CRLF & _
"teams:read:abc123:def234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")