using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:
(?P<entity>[^:]+)
(?::(?P<mode>[^:]+))?
(?P<paths>
(:(?P<path>[^:]+))+
)?
)
$";
string input = @"teams
teams:read
teams:read:abc123
teams:read:abc123:def234";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}