import re
regex = re.compile(r"^\/topic\/(?:.+-)*(\d+)", flags=re.MULTILINE)
test_str = "/post/cho-minh-hoi-voi-kien-thuc-ve-cc-va-sql-o-truong-dai-hoc-da-du-de-thuc-tap-chua-vay-moi-nguoi-minh-2131321-nghe-may-nguoi-da-tot-nghiep-noi-la-luc-di-lam-nguoi-ta-ko-dung-nhung-kien-thuc-trong-truong-dai-1321321321"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")