re = /(?<!\((?=[^()\n]*\))[^()\n]*)big/m
str = 'Should Match:
I like big cakes
I like (big cakes
I like big) cakes
I like xx big xx cakes
I like ( xx big xx cakes
I like xx big xx) cakes
Should not Match:
I like (big) cakes
I like (xx big xx) cakes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end