import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((((?P<Keys>dword|word|byte|int)[ \\n\\t]+)((?P<Names>[a-zA-Z0-9 _\\-\\$]+)))((\\[(?P<Range>[a-zA-Z0-9 \\t\\n]+)\\][ \\t\\n]+)|(?P<Pointer>[* \\t\\n]+)|)((=[ \\n\\t]+)([&*\"a-zA-Z0-9]+))(;))|(((?P<Others>int|string|word)[ \\t\\n]+)([a-zA-Z0-9\\n\\t]+)(;))";
final String string = "; When you use static method ;;; \n"
+ "dword moses = 25;\n"
+ "word $him-moses_christ = 344;\n"
+ "byte second[ 20 ] = 89;\n"
+ "int th * = \"moses\";\n"
+ "int moses;\n"
+ "int moses = \"christ\";\n"
+ "int moses [54] = christ;\n"
+ "calls with a large number of\n"
+ "regular expressions. \n"
+ "By default, the regular expression engine caches \n"
+ "the 15 most recently used static regular expressions. \n"
+ "If your application uses more than 15 static regular expressions, \n"
+ "some regular expressions must be recompiled. To prevent this recompilation,\n"
+ " you can increase the Regex.CacheSize property.(\\[([a-zA-Z0-9 ]+)\\])|([*]+)|[])";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}