use strict;
my $str = '; When you use static method ;;;
dword moses = 25;
word $him-moses_christ = 344;
byte second[ 20 ] = 89;
int th * = "moses";
int moses;
int moses = "christ";
int moses [54] = christ;
calls with a large number of
regular expressions.
By default, the regular expression engine caches
the 15 most recently used static regular expressions.
If your application uses more than 15 static regular expressions,
some regular expressions must be recompiled. To prevent this recompilation,
you can increase the Regex.CacheSize property.(\\[([a-zA-Z0-9 ]+)\\])|([*]+)|[])';
my $regex = qr`((((?P<Keys>dword|word|byte|int)[ \n\t]+)((?P<Names>[a-zA-Z0-9 _\-\$]+)))((\[(?P<Range>[a-zA-Z0-9 \t\n]+)\][ \t\n]+)|(?P<Pointer>[* \t\n]+)|)((=[ \n\t]+)([&*"a-zA-Z0-9]+))(;))|(((?P<Others>int|string|word)[ \t\n]+)([a-zA-Z0-9\n\t]+)(;))`p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}