const regex = /\\u[0-9]{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\u[0-9]{4}', 'gm')
const str = `\\u2347 \\u3413 4313
\\u0000 \\u123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}