$re = '/\\\\u[0-9]{4}/m';
$str = '\\u2347 \\u3413 4313
\\u0000 \\u123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);