$re = '/(?<![^_.])[^\W_]+|[^\W_]+(?=[._])/m';
$str = 'this_is.an_Example string for.You';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);