re = /(?<![^_.])[^\W_]+|[^\W_]+(?=[._])/m
str = 'this_is.an_Example string for.You'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end