$re = '~^[^/]+/(.*)/([^/]+/?)$~m';
$str = 'ejemplo.com/deportes/liga/futbol/espaƱol/otros/mas/categorias/mi-url-de-la-noticia/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);