re = /^[^\/]+\/(.*)\/([^\/]+\/?)$/m
str = 'ejemplo.com/deportes/liga/futbol/espaƱol/otros/mas/categorias/mi-url-de-la-noticia/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end