#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[\w\s])\s*[-+.'\w]+@[-.\w]+\.[-.\w]{2,}\s*$"
Local $sString = "yes@no.com" & @CRLF & _
"dfgdd@dghdfg.co.uk" & @CRLF & _
"dfg dfg" & @CRLF & _
"dfgdfd@gmail.co" & @CRLF & _
"dfgdfd@gmail.co " & @CRLF & _
"john@hotmail.com "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")