$re = '/^(?=[\w\s])\s*[-+.\'\w]+@[-.\w]+\.[-.\w]{2,}\s*$/m';
$str = 'yes@no.com
dfgdd@dghdfg.co.uk
dfg dfg
dfgdfd@gmail.co
dfgdfd@gmail.co
john@hotmail.com ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);