const regex = /">([^<]+)</gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('">([^<]+)<', 'gm')
const str = `<a class="_f5rco33" href="/account-settings"><div class="_ojs7nk">Account</div></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}