#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "import\s+(?:{[^{}]+}|.*?)\s*(?:from)?\s*['"].*?['"]|import\(.*?\)"
Local $sString = "import {" & @CRLF & _
" Component" & @CRLF & _
"} from '@angular2/core';" & @CRLF & _
"import defaultMember from "module-name";" & @CRLF & _
"import * as name from "module-name ";" & @CRLF & _
"import { member } from " module-name";" & @CRLF & _
"import { member as alias } from "module-name";" & @CRLF & _
"import { member1 , member2 } from "module-name";" & @CRLF & _
"import { member1 , member2 as alias2 , member3 as alias3 } from "module-name";" & @CRLF & _
"import {" & @CRLF & _
" Component" & @CRLF & _
"} from '@angular2/core';" & @CRLF & _
"import defaultMember from "$module-name";" & @CRLF & _
"import defaultMember, { member, member } from "module-name";" & @CRLF & _
"import defaultMember, * as name from "module-name";" & @CRLF & _
"" & @CRLF & _
"import * as name from "module-name "" & @CRLF & _
"import { member } from " module-name"" & @CRLF & _
"import { member as alias } from "module-name"" & @CRLF & _
"import { member1 , member2 } from "module-name"" & @CRLF & _
"import { member1 , member2 as alias2 , member3 as alias3 } from "module-name"" & @CRLF & _
"import {" & @CRLF & _
" Component" & @CRLF & _
"} from '@angular2/core'" & @CRLF & _
"import defaultMember from "$module-name"" & @CRLF & _
"import defaultMember, { member, member } from "module-name"" & @CRLF & _
"import defaultMember, * as name from "module-name"" & @CRLF & _
"" & @CRLF & _
"import "module-name";" & @CRLF & _
"import React from "react"" & @CRLF & _
"import { Field } from "redux-form"" & @CRLF & _
"import "module-name";" & @CRLF & _
"" & @CRLF & _
"import {" & @CRLF & _
" PlaneBufferGeometry," & @CRLF & _
" OctahedronGeometry," & @CRLF & _
" TorusBufferGeometry" & @CRLF & _
"} from '../geometries/Geometries.js';" & @CRLF & _
"" & @CRLF & _
"import {" & @CRLF & _
" PlaneBufferGeometry," & @CRLF & _
" OctahedronGeometry," & @CRLF & _
" TorusBufferGeometry" & @CRLF & _
"} from '../geometries/Geometries.js'" & @CRLF & _
"" & @CRLF & _
"import("whatever.js");" & @CRLF & _
"import("whatever.js")" & @CRLF & _
"" & @CRLF & _
"import { Field } from "redux-form";" & @CRLF & _
"import MultiContentListView from "./views/ListView";" & @CRLF & _
"import MultiContentAddView from "./views/AddView";" & @CRLF & _
"import MultiContentEditView from "./views/EditView";" & @CRLF & _
"" & @CRLF & _
"import { Field } from "redux-form"" & @CRLF & _
"import MultiContentListView from "./views/ListView"" & @CRLF & _
"import MultiContentAddView from "./views/AddView"" & @CRLF & _
"import MultiContentEditView from "./views/EditView"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<MenuItem value="^$" primaryText="Não exibir importados" />" & @CRLF & _
"<MenuItem value="\\w+" primaryText="Exibir importados" />" & @CRLF & _
"" & @CRLF & _
"// *Add all needed dependency to this module" & @CRLF & _
"// *app requires those import modules to function" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
"* " & @CRLF & _
" *Add all needed dependency to this module" & @CRLF & _
" *app requires those import modules to function" & @CRLF & _
" * " & @CRLF & _
"**/" & @CRLF & _
"" & @CRLF & _
"let modules = [];" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"import defaultExport from "module-name";" & @CRLF & _
"import * as name from "module-name";" & @CRLF & _
"import { export1 } from "module-name";" & @CRLF & _
"import { export1 as alias1 } from "module-name";" & @CRLF & _
"import { default as alias } from "module-name";" & @CRLF & _
"import { export1, export2 } from "module-name";" & @CRLF & _
"import { export1, export2 as alias2, /* … */ } from "module-name";" & @CRLF & _
"import { "string name" as alias } from "module-name";" & @CRLF & _
"import defaultExport, { export1, /* … */ } from "module-name";" & @CRLF & _
"import defaultExport, * as name from "module-name";" & @CRLF & _
"import "module-name";" & @CRLF & _
"import { "a-b" as a } from "/modules/my-module.js";" & @CRLF & _
"import myDefault from "/modules/my-module.js";" & @CRLF & _
"import myDefault, * as myModule from "/modules/my-module.js";" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")