# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"import\s+(?:{[^{}]+}|.*?)\s*(?:from)?\s*['\"].*?['\"]|import\(.*?\)"
test_str = ("import {\n"
" Component\n"
"} from '@angular2/core';\n"
"import defaultMember from \"module-name\";\n"
"import * as name from \"module-name \";\n"
"import { member } from \" module-name\";\n"
"import { member as alias } from \"module-name\";\n"
"import { member1 , member2 } from \"module-name\";\n"
"import { member1 , member2 as alias2 , member3 as alias3 } from \"module-name\";\n"
"import {\n"
" Component\n"
"} from '@angular2/core';\n"
"import defaultMember from \"$module-name\";\n"
"import defaultMember, { member, member } from \"module-name\";\n"
"import defaultMember, * as name from \"module-name\";\n\n"
"import * as name from \"module-name \"\n"
"import { member } from \" module-name\"\n"
"import { member as alias } from \"module-name\"\n"
"import { member1 , member2 } from \"module-name\"\n"
"import { member1 , member2 as alias2 , member3 as alias3 } from \"module-name\"\n"
"import {\n"
" Component\n"
"} from '@angular2/core'\n"
"import defaultMember from \"$module-name\"\n"
"import defaultMember, { member, member } from \"module-name\"\n"
"import defaultMember, * as name from \"module-name\"\n\n"
"import \"module-name\";\n"
"import React from \"react\"\n"
"import { Field } from \"redux-form\"\n"
"import \"module-name\";\n\n"
"import {\n"
" PlaneBufferGeometry,\n"
" OctahedronGeometry,\n"
" TorusBufferGeometry\n"
"} from '../geometries/Geometries.js';\n\n"
"import {\n"
" PlaneBufferGeometry,\n"
" OctahedronGeometry,\n"
" TorusBufferGeometry\n"
"} from '../geometries/Geometries.js'\n\n"
"import(\"whatever.js\");\n"
"import(\"whatever.js\")\n\n"
"import { Field } from \"redux-form\";\n"
"import MultiContentListView from \"./views/ListView\";\n"
"import MultiContentAddView from \"./views/AddView\";\n"
"import MultiContentEditView from \"./views/EditView\";\n\n"
"import { Field } from \"redux-form\"\n"
"import MultiContentListView from \"./views/ListView\"\n"
"import MultiContentAddView from \"./views/AddView\"\n"
"import MultiContentEditView from \"./views/EditView\"\n\n\n"
"<MenuItem value=\"^$\" primaryText=\"Não exibir importados\" />\n"
"<MenuItem value=\"\\\\w+\" primaryText=\"Exibir importados\" />\n\n"
"// *Add all needed dependency to this module\n"
"// *app requires those import modules to function\n\n\n"
"*/\n\n"
"/**\n"
"* \n"
" *Add all needed dependency to this module\n"
" *app requires those import modules to function\n"
" * \n"
"**/\n\n"
"let modules = [];\n\n\n"
"import defaultExport from \"module-name\";\n"
"import * as name from \"module-name\";\n"
"import { export1 } from \"module-name\";\n"
"import { export1 as alias1 } from \"module-name\";\n"
"import { default as alias } from \"module-name\";\n"
"import { export1, export2 } from \"module-name\";\n"
"import { export1, export2 as alias2, /* … */ } from \"module-name\";\n"
"import { \"string name\" as alias } from \"module-name\";\n"
"import defaultExport, { export1, /* … */ } from \"module-name\";\n"
"import defaultExport, * as name from \"module-name\";\n"
"import \"module-name\";\n"
"import { \"a-b\" as a } from \"/modules/my-module.js\";\n"
"import myDefault from \"/modules/my-module.js\";\n"
"import myDefault, * as myModule from \"/modules/my-module.js\";\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.