use strict;
my $str = '1.000.000.00.
';
my $regex = qr/[^0-9.]+|\.(?=\d+\.\d+|$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";