$re = '/[^0-9.]+|\.(?=\d+\.\d+|$)/m';
$str = '1.000.000.00.
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;