using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?xsm)
(.+) # copy-past replacement to ";
string substitution = @"$1 ";
string input = @"=IFERROR(
MAX(
INDEX(
raw_wells_prod!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
),
INDEX(
raw_wells_inj!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
)
),
0
) ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}