re = /(?xsm)
(.+) # copy-past replacement to /m
str = '=IFERROR(
MAX(
INDEX(
raw_wells_prod!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
),
INDEX(
raw_wells_inj!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
)
),
0
) '
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result