$re = '/(?:[^.]*\.){3}[\s\S]*/';
$str = 'This is the first sentence.
Second one.
Third.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);