re = /(?:[^.]*\.){3}[\s\S]*/
str = 'This is the first sentence.
Second one.
Third.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end