#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<.*>)(.*)(<.*>)(.*)"
Local $sString = " <html>" & @CRLF & _
" <head>" & @CRLF & _
" <title>Sample site</title>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <div>text<div>more text</div>and more...</div>in body" & @CRLF & _
" </body>" & @CRLF & _
" </html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")