using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<.*>)(.*)(<.*>)(.*)";
string input = @" <html>
<head>
<title>Sample site</title>
</head>
<body>
<div>text<div>more text</div>and more...</div>in body
</body>
</html>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}