re = /(.)/m
str = 'ÀÁÂÃÄÅ
àáâãäåÒÓÔÕÕÖØòóôõöøÈÉÊËèéêëěðÇČčçÐÌÍÎÏìíîïÙÚÛÜùúûüÑñŠšŸÿýŽž
AAAAAAaaaaaaOOOOOOOooooooEEEEeeeeeeCCccDIIIIiiiiUUUUuuuuNnSsYyyZz'
subst = '$1|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result