$re = '`//s3.amazonaws.com/([-A-z0-9.]+)`';
$str = '//s3.amazonaws.com/bucket.name/ and //s3.amazonaws.com/bucket-name-here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);