import re
regex = re.compile(r"//s3.amazonaws.com/([-A-z0-9.]+)")
test_str = "//s3.amazonaws.com/bucket.name/ and //s3.amazonaws.com/bucket-name-here"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")