#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)##\K[A-Z]+(?:_[A-Z]+)*(?=##)"
Local $sString = "class: ##TOPIC##-area" & @CRLF & _
" name: myClass" & @CRLF & _
"type: Class" & @CRLF & _
"secretKey: private-##SECRET_KEY##-encoded-##SUFFIX_CODE##"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")